re = /(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)/
str = '<div class="fw-bold">Финансовая отчетность за 2024 год</div>
'
subst = '$1$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result