package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)`)
var str = []byte(`<div class="fw-bold">Финансовая отчетность за 2024 год</div>
`)
var substitution = []byte("$1$2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}