$re = '/(<div\s+class=["\']fw-bold["\']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)/';
$str = '<div class="fw-bold">Финансовая отчетность за 2024 год</div>
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;