#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)"
Local $sString = "<div class="fw-bold">Финансовая отчетность за 2024 год</div>" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)