# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Better)(.)(Together)(.)(Stronger)/$1BecauseWeAreInThis$3WhichMakesUs$5/gm;t' <<< "Better.Together.Stronger"