$re = '/(Better)(.)(Together)(.)(Stronger)/m';
$str = 'Better.Together.Stronger';
$subst = "$1BecauseWeAreInThis$3WhichMakesUs$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;