package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Better)(.)(Together)(.)(Stronger)`)
var str = `Better.Together.Stronger`
var substitution = "$1BecauseWeAreInThis$3WhichMakesUs$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}