using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Better)(.)(Together)(.)(Stronger)";
string substitution = @"$1BecauseWeAreInThis$3WhichMakesUs$5";
string input = @"Better.Together.Stronger";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}