// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Better)(.)(Together)(.)(Stronger)").unwrap();
let string = "Better.Together.Stronger";
let substitution = "$1BecauseWeAreInThis$3WhichMakesUs$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}