import Foundation
let pattern = #"(Better)(.)(Together)(.)(Stronger)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Better.Together.Stronger"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1BecauseWeAreInThis$3WhichMakesUs$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)