re = /(Better)(.)(Together)(.)(Stronger)/m
str = 'Better.Together.Stronger'
subst = '$1BecauseWeAreInThis$3WhichMakesUs$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result