use strict;
my $str = 'Better.Together.Stronger';
my $regex = qr/(Better)(.)(Together)(.)(Stronger)/mp;
my $subst = '$1BecauseWeAreInThis$3WhichMakesUs$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";