# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bFOO\b(?![^[\]]*(?:\[\[[^[\]]*]][^[\]\n]*)*]])/BAZ/gm;t' <<< "Should match the following
lorem ipsum FOO dolor
lorem ipsum FOO dolor [[amet]]
[[lorem]] ipsum FOO dolor [[sit]] amet
Should NOT match the following
lorem ipsum [[FOO]] dolor
lorem [[ipsum FOO dolor]] sit amet
lorem [[ipsumFOOsolor]] sit amet
[[lorem]]
[[ipsum-FOO&dolor-sit.pdf#page=130]]
lorem ipsumFOOsolor sit amet
FOO should be matched below but is not because the double-brackets are not balanced.
lorem FOO [[ipsumFOOsolor]] sit ]] amet"