$re = '/\bFOO\b(?![^[\]]*(?:\[\[[^[\]]*]][^[\]\n]*)*]])/m';
$str = 'Should match the following
lorem ipsum FOO dolor
lorem ipsum FOO dolor [[amet]]
[[lorem]] ipsum FOO dolor [[sit]] amet
Should NOT match the following
lorem ipsum [[FOO]] dolor
lorem [[ipsum FOO dolor]] sit amet
lorem [[ipsumFOOsolor]] sit amet
[[lorem]]
[[ipsum-FOO&dolor-sit.pdf#page=130]]
lorem ipsumFOOsolor sit amet
FOO should be matched below but is not because the double-brackets are not balanced.
lorem FOO [[ipsumFOOsolor]] sit ]] amet';
$subst = "BAZ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;