import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bFOO\\b(?![^[\\]]*(?:\\[\\[[^[\\]]*]][^[\\]\\n]*)*]])";
final String string = "Should match the following\n"
+ "lorem ipsum FOO dolor\n"
+ "lorem ipsum FOO dolor [[amet]]\n"
+ "[[lorem]] ipsum FOO dolor [[sit]] amet\n\n"
+ "Should NOT match the following\n"
+ "lorem ipsum [[FOO]] dolor\n"
+ "lorem [[ipsum FOO dolor]] sit amet\n"
+ "lorem [[ipsumFOOsolor]] sit amet\n"
+ "[[lorem]]\n"
+ "[[ipsum-FOO&dolor-sit.pdf#page=130]]\n"
+ "lorem ipsumFOOsolor sit amet\n\n"
+ "FOO should be matched below but is not because the double-brackets are not balanced.\n"
+ "lorem FOO [[ipsumFOOsolor]] sit ]] amet";
final String subst = "BAZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}