using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bFOO\b(?![^[\]]*(?:\[\[[^[\]]*]][^[\]\n]*)*]])";
string substitution = @"BAZ";
string input = @"Should match the following
lorem ipsum FOO dolor
lorem ipsum FOO dolor [[amet]]
[[lorem]] ipsum FOO dolor [[sit]] amet
Should NOT match the following
lorem ipsum [[FOO]] dolor
lorem [[ipsum FOO dolor]] sit amet
lorem [[ipsumFOOsolor]] sit amet
[[lorem]]
[[ipsum-FOO&dolor-sit.pdf#page=130]]
lorem ipsumFOOsolor sit amet
FOO should be matched below but is not because the double-brackets are not balanced.
lorem FOO [[ipsumFOOsolor]] sit ]] amet";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}