use strict;
my $str = 'Should match the following
lorem ipsum FOO dolor
lorem ipsum FOO dolor [[amet]]
[[lorem]] ipsum FOO dolor [[sit]] amet
Should NOT match the following
lorem ipsum [[FOO]] dolor
lorem [[ipsum FOO dolor]] sit amet
lorem [[ipsumFOOsolor]] sit amet
[[lorem]]
[[ipsum-FOO&dolor-sit.pdf#page=130]]
lorem ipsumFOOsolor sit amet
FOO should be matched below but is not because the double-brackets are not balanced.
lorem FOO [[ipsumFOOsolor]] sit ]] amet';
my $regex = qr/\bFOO\b(?![^[\]]*(?:\[\[[^[\]]*]][^[\]\n]*)*]])/mp;
my $subst = 'BAZ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";