# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\\/h[1-6]>/<p class="heading-${1}" ${2}>${3}<\/p>/gmsi;t' <<< "<h1 style=\"color:black\">test1</h1>
<H2 class=\"green\">test2</H2>
<h5 class=\"red\">test</h5>
<h5 class=\"\">test test</h5>"