import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h([1-6])\\s*((?:(?!class).)*?)>(.*?)<\\/h[1-6]>";
final String string = "<h1 style=\"color:black\">test1</h1>\n"
+ "<H2 class=\"green\">test2</H2>\n"
+ "<h5 class=\"red\">test</h5>\n"
+ "<h5 class=\"\">test test</h5>";
final String subst = "<p class=\"heading-${1}\" ${2}>${3}</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}