re = /<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>/mi
str = '<h1 style="color:black">test1</h1>
<H2 class="green">test2</H2>
<h5 class="red">test</h5>
<h5 class="">test test</h5>'
subst = '<p class="heading-${1}" ${2}>${3}</p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result