import Foundation
let pattern = #"<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<h1 style="color:black">test1</h1>
<H2 class="green">test2</H2>
<h5 class="red">test</h5>
<h5 class="">test test</h5>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p class="heading-${1}" ${2}>${3}</p>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)