$re = '/<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>/msi';
$str = '<h1 style="color:black">test1</h1>
<H2 class="green">test2</H2>
<h5 class="red">test</h5>
<h5 class="">test test</h5>';
$subst = "<p class=\"heading-${1}\" ${2}>${3}</p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;