using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>";
string substitution = @"<p class=""heading-${1}"" ${2}>${3}</p>";
string input = @"<h1 style=""color:black"">test1</h1>
<H2 class=""green"">test2</H2>
<h5 class=""red"">test</h5>
<h5 class="">test test</h5>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}