#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?msi)<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>"
Local $sString = "<h1 style="color:black">test1</h1>" & @CRLF & _
"<H2 class="green">test2</H2>" & @CRLF & _
"<h5 class="red">test</h5>" & @CRLF & _
"<h5 class="">test test</h5>"
Local $sSubst = "<p class="heading-${1}" ${2}>${3}</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)