use strict;
my $str = '<h1 style="color:black">test1</h1>
<H2 class="green">test2</H2>
<h5 class="red">test</h5>
<h5 class="">test test</h5>';
my $regex = qr/<h([1-6])\s*((?:(?!class).)*?)>(.*?)<\/h[1-6]>/msip;
my $subst = '<p class="heading-${1}" ${2}>${3}</p>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";