# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])/ /gm;t' <<< "SMThingAnotherThingBIGCapitalLetters"