import Foundation
let pattern = #"\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"SMThingAnotherThingBIGCapitalLetters"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)