#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])"
Local $sString = "SMThingAnotherThingBIGCapitalLetters"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)