re = /\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])/m
str = 'SMThingAnotherThingBIGCapitalLetters'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result