using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])";
string substitution = @" ";
string input = @"SMThingAnotherThingBIGCapitalLetters";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}