const regex = /\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?=[A-Z][a-z])|(?<=[a-z])\\B(?=[A-Z])', 'gm')
const str = `SMThingAnotherThingBIGCapitalLetters`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);