use strict;
my $str = 'SMThingAnotherThingBIGCapitalLetters';
my $regex = qr/\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";