$re = '/\B(?=[A-Z][a-z])|(?<=[a-z])\B(?=[A-Z])/m';
$str = 'SMThingAnotherThingBIGCapitalLetters';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;