#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)((?:[^\?]*/)?)($|\?.*)"
Local $sString = "https://customDomainName/BlobStorageName/4"
Local $sSubst = ".json"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)