const regex = new RegExp('((?:[^\\?]*/)?)($|\\?.*)', 'im')
const str = `https://customDomainName/BlobStorageName/4`;
const subst = `.json`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);