// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)((?:[^\?]*/)?)($|\?.*)").unwrap();
let string = "https://customDomainName/BlobStorageName/4";
let substitution = ".json";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}