re = /((?:[^\?]*\/)?)($|\?.*)/im
str = 'https://customDomainName/BlobStorageName/4'
subst = '.json'
result = str.sub(re, subst)
# Print the result of the substitution
puts result