$re = '/((?:[^\?]*/)?)($|\?.*)/im';
$str = 'https://customDomainName/BlobStorageName/4';
$subst = ".json";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;