import Foundation
let pattern = #"((?:[^\?]*/)?)($|\?.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"https://customDomainName/BlobStorageName/4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".json"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}