import re
regex = re.compile(r"((?:[^\?]*/)?)($|\?.*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "https://customDomainName/BlobStorageName/4"
subst = ".json"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)