use strict;
my $str = 'https://customDomainName/BlobStorageName/4';
my $regex = qr/((?:[^\?]*/)?)($|\?.*)/imp;
my $subst = '.json';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";