import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|\")[^\"\\s]*\\K(?:\\s|\"(*SKIP)(*F))";
final String string = "good with spaces \"here all spaces sould be removed\" and here allso good\n"
+ "good with spaces \"here all spaces sould be removed\" and here allso good";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}