$re = '/(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))/m';
$str = 'good with spaces "here all spaces sould be removed" and here allso good
good with spaces "here all spaces sould be removed" and here allso good';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;