import Foundation
let pattern = #"(?:\G(?!\A)|")[^"\s]*\K(?:\s|"(*SKIP)(*F))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
good with spaces "here all spaces sould be removed" and here allso good
good with spaces "here all spaces sould be removed" and here allso good
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)