# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"((http|https)\:\\/\\/([^\"]+)\.key)\"//gm;t' <<< "<a href=\"http://site.com/palavra.key\"></a>
<a href=\"https://site.com/palavra.key\"></a>
<a href=\"http://subdominio.site.com/palavra.key\"></a>
<a href=\"https://subdominio.site.com/palavra.chave\"></a>
<a href=\"http://subdominio.site.com/uma_coisa_qualquer.keykey\"></a>
<a href=\"https://subdominio.site.com/outra_coisa_qualquer.key\"></a>
<a href=\"https://subdominio.site.com/outra_coisa_qualquer.keys\"></a>
"