import re
regex = re.compile(r"\"((http|https)\:\/\/([^\"]+)\.key)\"", flags=re.MULTILINE)
test_str = ("<a href=\"http://site.com/palavra.key\"></a>\n"
"<a href=\"https://site.com/palavra.key\"></a>\n"
"<a href=\"http://subdominio.site.com/palavra.key\"></a>\n"
"<a href=\"https://subdominio.site.com/palavra.chave\"></a>\n"
"<a href=\"http://subdominio.site.com/uma_coisa_qualquer.keykey\"></a>\n"
"<a href=\"https://subdominio.site.com/outra_coisa_qualquer.key\"></a>\n"
"<a href=\"https://subdominio.site.com/outra_coisa_qualquer.keys\"></a>\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)