const regex = /\"((http|https)\:\/\/([^\"]+)\.key)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"((http|https)\\:\\\/\\\/([^\\"]+)\\.key)\\"', 'gm')
const str = `<a href="http://site.com/palavra.key"></a>
<a href="https://site.com/palavra.key"></a>
<a href="http://subdominio.site.com/palavra.key"></a>
<a href="https://subdominio.site.com/palavra.chave"></a>
<a href="http://subdominio.site.com/uma_coisa_qualquer.keykey"></a>
<a href="https://subdominio.site.com/outra_coisa_qualquer.key"></a>
<a href="https://subdominio.site.com/outra_coisa_qualquer.keys"></a>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);