package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"((http|https)\:\/\/([^\"]+)\.key)\"`)
var str = `<a href="http://site.com/palavra.key"></a>
<a href="https://site.com/palavra.key"></a>
<a href="http://subdominio.site.com/palavra.key"></a>
<a href="https://subdominio.site.com/palavra.chave"></a>
<a href="http://subdominio.site.com/uma_coisa_qualquer.keykey"></a>
<a href="https://subdominio.site.com/outra_coisa_qualquer.key"></a>
<a href="https://subdominio.site.com/outra_coisa_qualquer.keys"></a>
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}