import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"((http|https)\\:\\/\\/([^\\\"]+)\\.key)\\\"";
final String string = "<a href=\"http://site.com/palavra.key\"></a>\n"
+ "<a href=\"https://site.com/palavra.key\"></a>\n"
+ "<a href=\"http://subdominio.site.com/palavra.key\"></a>\n"
+ "<a href=\"https://subdominio.site.com/palavra.chave\"></a>\n"
+ "<a href=\"http://subdominio.site.com/uma_coisa_qualquer.keykey\"></a>\n"
+ "<a href=\"https://subdominio.site.com/outra_coisa_qualquer.key\"></a>\n"
+ "<a href=\"https://subdominio.site.com/outra_coisa_qualquer.keys\"></a>\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}