using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""((http|https)\:\/\/([^\""]+)\.key)\""";
string substitution = @"";
string input = @"<a href=""http://site.com/palavra.key""></a>
<a href=""https://site.com/palavra.key""></a>
<a href=""http://subdominio.site.com/palavra.key""></a>
<a href=""https://subdominio.site.com/palavra.chave""></a>
<a href=""http://subdominio.site.com/uma_coisa_qualquer.keykey""></a>
<a href=""https://subdominio.site.com/outra_coisa_qualquer.key""></a>
<a href=""https://subdominio.site.com/outra_coisa_qualquer.keys""></a>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}